Re: [exim] Bug in string expansion of exim configuration?

Top Page

Reply to this message
Author: Jasen Betts
Date:  
To: exim-users
Subject: Re: [exim] Bug in string expansion of exim configuration?
On 2016-12-23, Forum <forum@???> wrote:
> Am 22.12.2016 um 20:22 schrieb Jasen Betts:
>
> As i remeber i did get the same error message in exim 4.84 before with the string without this parenthesis.
> "eval:10*${lookup" causes the same error crying for a parenthesis.
>
> But this string worked before in the delivery section of exim 4.80.
> Here the string that is currently in usage: "{${eval:10*${lookup mysql{ SELECT DISTINCT spam_threshold ..."
> So the behaviour of exim has changed.
>
> When i have a look at the documentation:
> http://www.exim.org/exim-html-current/doc/html/spec_html/ch-string_expansions.html
> i can't find anything about using normal ( parenthesis ). Everywhere {} is used, so i expected to use this.


It says parentheses in the second sentence in the section about ${eval:
and two of the example expressions in that section use parentheses.

--
This email has not been checked by half-arsed antivirus software