Attached is a patch with the following suggestions:
1. In branch_chain rename the "current" member to "current_b" - to
prevent a collision with the Linux macro when compiled as a kernel module
2. In compile_branch() use casting to int64_t rather then double - no
need for FP.
3. Rename set_bit() to pcre_set_bit() - to prevent a collision with the
Linux macro when compiled as a kernel module
4. In pcre_internal.h – remove obsolete includes to setjmp.h and stdarg.h
5. Use PCRE_DEBUG definition instead of DEBUG – to distinguish pcre
debugs.
Thanks,
E.