On Tue, 20 Oct 2009, Eldar Kleiner wrote:
> Attached is a patch with the following suggestions:
>
> 1. In branch_chain rename the "current" member to "current_b" - to
> prevent a collision with the Linux macro when compiled as a kernel module
Gulp. I never envisaged PCRE being compiled as a kernel module.
> 2. In compile_branch() use casting to int64_t rather then double - no
> need for FP.
int64_t is not Standard C, is it? I don't know which systems do/don't
support int64_t, but I have to be very careful to keep the code of PCRE
as standard as possible.
> 3. Rename set_bit() to pcre_set_bit() - to prevent a collision with the
> Linux macro when compiled as a kernel module
> 4. In pcre_internal.h ? remove obsolete includes to setjmp.h and stdarg.h
Good point.
> 5. Use PCRE_DEBUG definition instead of DEBUG ? to distinguish pcre
> debugs.
Again, I didn't envisage PCRE being compiled as part of something else,
but of course there's no harm.
Patch noted for when I next work on the code. Thanks for the
suggestions.
Philip
--
Philip Hazel