On Tue, 20 Oct 2009, Eldar Kleiner wrote:
> Attached is a patch with the following suggestions:
>
> 1. In branch_chain rename the "current" member to "current_b" - to
> prevent a collision with the Linux macro when compiled as a kernel module
> 2. In compile_branch() use casting to int64_t rather then double - no
> need for FP.
> 3. Rename set_bit() to pcre_set_bit() - to prevent a collision with the
> Linux macro when compiled as a kernel module
> 4. In pcre_internal.h ? remove obsolete includes to setjmp.h and stdarg.h
> 5. Use PCRE_DEBUG definition instead of DEBUG ? to distinguish pcre
> debugs.
I have applied slightly modified versions of these patches, and
committed them to the svn repository. In the case of number 2 I have
changed the configuration code so that it looks for the presence of
int64_t; if it is not found, it falls back to double. On my Linux box it
does find int64_t. Hopefully it will work in environments that lack it.
I know that people compile PCRE in all sorts of strange environments. :-)
Regards,
Philip
--
Philip Hazel