[exim] error building exim 4.67 on solaris 9

Top Page

Reply to this message
Author: Dave Lugo
Date:  
To: exim-users
Subject: [exim] error building exim 4.67 on solaris 9
Hi,

I'm trying to build the latest exim with ldap & tls on solaris 9,
and I'm getting this error:

--snip preceeding stuff which compiled fine--
gcc -o exim

Undefined                       first referenced
 symbol                             in file


dlsym                               /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)  (symbol belongs to implicit dependency /usr/lib/libdl.so.1)
dlopen                              /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)  (symbol belongs to implicit dependency /usr/lib/libdl.so.1)
dlclose                             /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)  (symbol belongs to implicit dependency /usr/lib/libdl.so.1)
dlerror                             /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)  (symbol belongs to implicit dependency /usr/lib/libdl.so.1)
ld: fatal: Symbol referencing errors. No output written to exim
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `exim'
Current working directory /usr/share/src/exim/exim-4.67/build-SunOS5-5.9-sparc
*** Error code 1
make: Fatal error: Command failed for target `go'



Suggestions on how to get past this?

Thanks,

Dave

-- 
--------------------------------------------------------
Dave Lugo   dlugo@???    LC Unit #260   TINLC
Have you hugged your firewall today?   No spam, thanks.
--------------------------------------------------------
Are you the police?  . . . .  No ma'am, we're sysadmins.