Re: [pcre-dev] [PATCH] pcre1 modify misleading error message

Top Page

Reply to this message
Author: ph10
Date:  
To: Benjamin Chaney
CC: pcre-dev
Subject: Re: [pcre-dev] [PATCH] pcre1 modify misleading error message
On Thu, 15 Mar 2018, Benjamin Chaney via Pcre-dev wrote:

> Index: configure.ac
> ===================================================================
> --- configure.ac    (revision 1729)
> +++ configure.ac    (working copy)
> @@ -481,7 +481,7 @@
>  pcre_have_bits_type_traits="0"

>
> if test "x$enable_cpp" = "xyes" -a -z "$CXX"; then
> - AC_MSG_ERROR([You need a C++ compiler for C++ support.])
> + AC_MSG_ERROR([Invalid C++ compiler or C++ compiler flags])
> fi


Thanks for the report. I have sneaked this into the forthcoming 8.42
release which I will probably put out tomorrow (it's been on test for a
month).

Philip

--
Philip Hazel