On Tue, 30 Oct 2007, Ted Cooper wrote:
> The "require" action. It's in the same boat as deny, accept, defer in
> that it is the start of an acl segment in itself.
I find for clarity that is is better to write ACL blocks like so:
deny
condition = whatever
log_message = blah blah
require
senders = friendly
accept
Jethro.
What you have above
> are 2 separate acl blocks
> # DENY BLOCK
> deny message = not permitted to contact user
> log_message = not on whitelist
> condition = ${if exists{/home/$local_part/.whitelist}{yes}{no}}
> # END OF DENY BLOCK
>
> # START OF NEW REQUIRE BLOCK
> require senders = /home/$local_part/.whitelist
> # END REQUIRE BLOCK
>
>
> Just cut out the require keyword and it .. might work :P This is the
> general idea but I don't think it's quite right. It might not need the
> lsearch in there .. or it might need a ${lookup}
>
> deny message = not permitted
> log_message = no in whilelist
> condition = ${if exists{$home/.whitelist}{yes}{no}}
> ! senders = lsearch;/home/$local_part/.whitelist
>
>
> --
> The Exim Manual
> http://www.exim.org/docs.html
> http://www.exim.org/exim-html-current/doc/html/spec_html/index.html
>
> --
> ## List details at http://lists.exim.org/mailman/listinfo/exim-users
> ## Exim details at http://www.exim.org/
> ## Please use the Wiki with this list - http://wiki.exim.org/
>
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Jethro R Binks
Computing Officer, IT Services
University Of Strathclyde, Glasgow, UK