[pcre-dev] [Bug 2469] New: Portability fix for secure_getenv…

Top Page

Reply to this message
Author: admin
Date:  
To: pcre-dev
New-Topics: [pcre-dev] [Bug 2469] Portability fix for secure_getenv usage
Subject: [pcre-dev] [Bug 2469] New: Portability fix for secure_getenv usage
https://bugs.exim.org/show_bug.cgi?id=2469

            Bug ID: 2469
           Summary: Portability fix for secure_getenv usage
           Product: PCRE
           Version: 10.34 (PCRE2)
          Hardware: All
                OS: NetBSD
            Status: NEW
          Severity: bug
          Priority: medium
         Component: Code
          Assignee: ph10@???
          Reporter: tk@???
                CC: pcre-dev@???


Created attachment 1230
--> https://bugs.exim.org/attachment.cgi?id=1230&action=edit
Patch fixing the problem.

On NetBSD, the default JIT does not work with PaX mprotect enabled (the
default).
The SE Linux version fares better, but there is a compilation problem. The
configure script checks for secure_getenv, but the code does not. The attached
patch fixes this.

--
You are receiving this mail because:
You are on the CC list for the bug.