Re: [exim] TLS unsupported protocol?

Top Page

Reply to this message
Author: Cyborg
Date:  
To: exim-users
Subject: Re: [exim] TLS unsupported protocol?
Am 03.09.19 um 01:01 schrieb Mike Tubby via Exim-users:
> I have someone connecting to me repeatedly and failing on TLS/SSL
> start up, thus:
>
> 2019-09-02 23:57:30 CONNECT: New connection from 80.82.32.21:62950 ->
> 195.171.43.32:25
> 2019-09-02 23:57:30 CONNECT: Accepting connection from: 80.82.32.21 -
> not blocked by any RBL
> 2019-09-02 23:57:30 HELO: Accepted HELO/EHLO serv13.vsi.ru from remote
> host: 80.82.32.21 (serv13.vsi.ru)
> 2019-09-02 23:57:30 CRYPTO: Client 80.82.32.21:62950 issued STARTTLS
> 2019-09-02 23:57:30 TLS error on connection from serv13.vsi.ru
> [80.82.32.21] (SSL_accept): error:14209102:SSL
> routines:tls_early_post_process_client_hello:unsupported protocol
>
> is this just a case of them using SSLv2 or something I don't have
> enabled at my end?
>
> Mike
>
>


Not worth thinking about that badly configured server:

Trying TLS on 80.82.32.21[80.82.32.21:25] (0):

seconds     
    test stage and result
[000.145]     
    Connected to server
[006.035]     <--      220-serv13.vsi.ru ESMTP Sendmail 8.14.2/8.14.2; Tue, 3
Sep 2019 11:17:58 +0400 (MSK)
220-Use of this system for the delivery of UCE (a.k.a. SPAM), or any other
220-message without the express permission of the system owner is
prohibited.
220 Use of this system for third party relaying is prohibited.
[006.035]     
    We are allowed to connect
[006.036]      -->     EHLO www6.CheckTLS.com
[006.179]     <--      
[006.179]     
    Remote did not return keyword (capabilities) list
[006.179]     
    Lost connection