Re: [exim] failed to unlink *-J in queue

Top Page

Reply to this message
Author: Kerstin
Date:  
To: exim-users
Subject: Re: [exim] failed to unlink *-J in queue
Am 07.09.2014 um 13:22 schrieb Jeremy Harris:
>> The mainlog shows delivery of the mail:
>
>
>>
>> 2014-09-04 03:23:10 1XPLlL-0001GW-6S >> user@???
>> R=domain_smart_route T=remote_smtp H=remote.domain.de [XXX]
>> C="250 2.6.0
>> <D5C8F9B36700C60B7C929BB4CF95D6528F5F1A629288305F-74616e87f3c647681c024ad865706e23@???>
>>
>>
>
>>
>>

[InternalId=458] Queued mail for delivery"
>> 2014-09-04 03:23:10 1XPLlL-0001GW-6S <= user@???
>> H=XXX.domain.cl [XXX] P=esmtp S=6566
>> id=D5C8F9B36700C60B7C929BB4CF95D6528F5F1A629288305F-74616e87f3c647681c024ad865706e23@???
>>
>>
>
>>
>>

for user@???
>> 2014-09-04 03:23:10 1XPLlL-0001GW-6S Completed
>>
>> +++ 1XPLlL-0001GW-6S has not completed +++ 2014-09-04 03:23:11
>> 1XPLlL-0001GW-6S => user@??? R=domain_smart_route
>> T=remote_smtp H=remote.domain.de [XXX] C="250 2.6.0
>> <D5C8F9B36700C60B7C929BB4CF95D6528F5F1A629288305F-74616e87f3c647681c024ad865706e23@???>
>>
>>
>
>>
>>

[InternalId=459] Queued mail for delivery"
>> 2014-09-04 03:23:11 1XPLlL-0001GW-6S failed to unlink
>> /var/spool/exim4/msglog/L/1XPLlL-0001GW-6S: No such file or
>> directory
>
> To clarify - this was all in mainlog?


Yes, it is.

In paniclog are only these two lines:

# exigrep 1XPLlL-0001GW-6S paniclog*
+++ 1XPLlL-0001GW-6S has not completed +++
2014-09-04 03:23:11 1XPLlL-0001GW-6S failed to unlink
/var/spool/exim4/msglog/L/1XPLlL-0001GW-6S: No such file or directory

> If so, you also got a duplicate delivery, done within a couple of
> seconds. How often are your queue-runners ticking? Are you doing
> anything nonstandard to run the queue?


The customer did not complain about double delivery.:-)

The queue runner is only startet from the deamonized exim process:
/usr/local/bin/exim -bd -q30m
No start from cron.
>
> I'm having trouble tracing the source that produces "+++
> 1XPLlL-0001GW-6S has not completed +++"
>

We have round about 150-300 cutthrough-deliveries per day, but only
1-3 "failed to unlink" messages in paniclog. Until now, I have no idea
how to reproduce the error.

- --
Regards,

Kerstin