[exim] failed to unlink *-J in queue

Top Page

Reply to this message
Author: Kerstin
Date:  
To: Exim users
Subject: [exim] failed to unlink *-J in queue


Hello,

since upgrading to exim 4.82 and enabling cutthrough delivery for some
customers our paniclog shows now and then entries like this:

...
2014-09-04 03:23:11 1XPLlL-0001GW-6S failed to unlink
/var/spool/exim4/msglog/L/1XPLlL-0001GW-6S: No such file or directory
2014-09-04 10:51:30 1XPSkx-0000dv-Af failed to unlink
/var/spool/exim4/msglog/x/1XPSkx-0000dv-Af: No such file or directory
2014-09-04 13:53:17 1XPVbB-0000tE-9C failed to unlink
/var/spool/exim4/msglog/B/1XPVbB-0000tE-9C: No such file or directory
...

The files *-J stuck in the spool dir, *-H and *-D are removed.

The mainlog shows delivery of the mail:

2014-09-04 03:23:10 1XPLlL-0001GW-6S >> user@???
R=domain_smart_route T=remote_smtp H=remote.domain.de [XXX] C="250
2.6.0
<D5C8F9B36700C60B7C929BB4CF95D6528F5F1A629288305F-74616e87f3c647681c024ad865706e23@???>
[InternalId=458] Queued mail for delivery"
2014-09-04 03:23:10 1XPLlL-0001GW-6S <= user@??? H=XXX.domain.cl
[XXX] P=esmtp S=6566
id=D5C8F9B36700C60B7C929BB4CF95D6528F5F1A629288305F-74616e87f3c647681c024ad865706e23@???
for user@???
2014-09-04 03:23:10 1XPLlL-0001GW-6S Completed

+++ 1XPLlL-0001GW-6S has not completed +++
2014-09-04 03:23:11 1XPLlL-0001GW-6S => user@???
R=domain_smart_route T=remote_smtp H=remote.domain.de [XXX] C="250
2.6.0
<D5C8F9B36700C60B7C929BB4CF95D6528F5F1A629288305F-74616e87f3c647681c024ad865706e23@???>
[InternalId=459] Queued mail for delivery"
2014-09-04 03:23:11 1XPLlL-0001GW-6S failed to unlink
/var/spool/exim4/msglog/L/1XPLlL-0001GW-6S: No such file or directory

The problem occurs only with cutthrough delivery and remains with exim
4.84.

Anyone else seeing this behaviour?

- --
Best regards,

Kerstin