[pcre-dev] [Bug 1207] Wrong setting of library version

Top Page

Reply to this message
Author: Juergen Daubert
To: pcre-dev
Subject: [pcre-dev] [Bug 1207] Wrong setting of library version
------- You are receiving this mail because: -------
You are on the CC list for the bug.


--- Comment #2 from Juergen Daubert <jue@???> 2012-02-06 11:45:58 ---
> I think it is, strictly, necessary. The function pcre_info(), which has
> been obsolete for 10 years, was removed from the API. It did not seem
> sensible to perpetuate the obsolescence by inventing a matching
> pcre16_info(). Any program that still uses pcre_info() will fail with
> 8.30 and re-linking should show that up.

Ok, I see, so my report is invalid, thanks for the explanation.

I did some tests and find that php fails to link against pcre 8.30, I guess
that a lot of others will fail as well. With that in mind I tend to say that a
greater jump the version number for pcre might be at least worth considering.

Thanks and regards

Configure bugmail: http://bugs.exim.org/userprefs.cgi?tab=email