[exim-dev] [Bug 97] outgoing tls_on_connect

Top Page

Reply to this message
Author: Git Commit
Date:  
To: exim-dev
Subject: [exim-dev] [Bug 97] outgoing tls_on_connect
------- You are receiving this mail because: -------
You are the QA contact for the bug.

http://bugs.exim.org/show_bug.cgi?id=97

Nigel Metheringham <nigel@???> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
   Target Milestone|Exim 4.76                   |Exim 4.77


Git Commit <git@???> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |git@???





--- Comment #9 from Git Commit <git@???> 2011-08-28 20:17:12 ---
Git commit:
http://git.exim.org/exim.git/commitdiff/061b7ebd7d69db7674f03025d552fa0bedd0fef8

commit 061b7ebd7d69db7674f03025d552fa0bedd0fef8
Author:     Phil Pennock <pdp@???>
AuthorDate: Sat Aug 27 14:43:09 2011 -0700
Commit:     Phil Pennock <pdp@???>
CommitDate: Sat Aug 27 14:43:09 2011 -0700


    add protocol=smtps support to smtp transport.


    permits ssl-on-connect for outbound connections.


    heavily based on simon arlott's patch, but with enough modifications to
    risk new bugs.


    nb: am on a plane, change confirmed to compile on macos, nothing more


    fixes bug 97
----
 doc/doc-docbook/spec.xfpt |   10 +++++
 doc/doc-txt/ChangeLog     |    4 ++
 doc/doc-txt/NewStuff      |    3 ++
 src/src/transports/smtp.c |   87 ++++++++++++++++++++++++++++++++++++---------
 4 files changed, 87 insertions(+), 17 deletions(-)



--
Configure bugmail: http://bugs.exim.org/userprefs.cgi?tab=email