[exim-dev] [Bug 478] New: Compile error with openssl 0.9.8e

Top Page

Reply to this message
Author: bug478
Date:  
To: exim-dev
Subject: [exim-dev] [Bug 478] New: Compile error with openssl 0.9.8e
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

http://www.exim.org/bugzilla/show_bug.cgi?id=478

           Summary: Compile error with openssl 0.9.8e
           Product: Exim
           Version: 4.66
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: bug
          Priority: high
         Component: TLS
        AssignedTo: ph10@???
        ReportedBy: jue@???
         QAContact: exim-dev@???



Got the following error while trying to compile exim 4.66 with openssl 0.9.8e,
works with 0.9.8d though (gcc 4.1.2):

gcc tls.c
In file included from tls.c:86:
tls-openssl.c: In function 'tls_init':
tls-openssl.c:346: error: wrong type argument to unary exclamation mark
make[1]: *** [tls.o] Error 1

--
Configure bugmail: http://www.exim.org/bugzilla/userprefs.cgi?tab=email